About OS X 10.9 Mavericks

There are known vulnerabilities for Mac OS X 10.9 "Mavericks" that are not addressed by Apple. Users should migrate as soon as possible to a fully supported version of OS X, see https://information-technology.web.cern.ch/services/fe/howto/software-updates-mac.

Mac OS X 10.9 Mavericks is available since October 22nd 2013. It can be installed directly from the Apple AppStore, or via our NetInstall server (see https://information-technology.web.cern.ch/services/fe/howto/install-os-... for details anbout our NetInstall service).

There are three important actions to take before you install Mavericks:

  1. Ensure that all the software you are using is compatible with it.
  2. Verify your hard-disk or SSD before doing the install.
  3. Make sure you have a recent backup, allowing you to recover your data in case of problems

Known Issues

Here we summarise a list of known issues that has been brought to our attention. Please note that this list is by no means complete.

Authentication

Using Network Groups from Active Directory (egroups in CERN speak) does not work properly. It might work for accounts that are members of few egroups only.

External Hard Disks

Western digital is warning anout potential data loss when using its drive manger software under Mavericks. Details are available from http://community.wd.com/t5/News-Announcements/External-Drives-for-Mac-Ex... . Users of Western Digital drives should uninstall the WD Drive Manager, WD Raid Manager and/or WD SmartWare before upgrading to OS 10.9.

Mobile device syncing

Mavericks has disabled local syncing of most data, you have to use iCloud for syncing of most data types. Depending on your settings this might include (and thus expose) all the passwords  stored in your keychain!

Openafs

OS X 10.9 requires openAFS version 1.6.6, released on January 24th 2014, or higher. The version 1.6.5 for Mountain Lion appears to work for most cases, but there is a problem when editing files in afs directly from emacs or when creating symlinks within the afs space. The 1.6.5 installer for Mountain Lion refuses to install on Mavericks, so if you want to use it on Mavericks you must install it before you migrate or hack the install package to disable the OS version check.

ROOT

ROOT v5-34-12 builds and runs fine on Mavericks. Previous versions don't and won't.

XQuartz

The XQuartz developers recommend to use 2.7.5 or later (http://xquartz.macosforge.org/landing).

You are here